リソースのグループ管理がうまく機能しません  【解決済み】

質問全般・改善要望
shiokari
メンバー
メンバー
記事: 29
登録日時: 2014年7月18日(金) 20:50

リソースのグループ管理がうまく機能しません

投稿記事by shiokari » 2019年8月20日(火) 17:23

-----
利用中のサーバ さくらのレンタルサーバ(スタンダード)
OS FreeBSD 9.1-RELEASE-p24
PHPのバージョン 7.3.7
セーフモード off
php_sapi_name cgi-fcgi
MySQLのバージョン 5.5.59-log
MODXのバージョン 1.0.22J
-----

いつもお世話になっております。
ひょっとしたら同様のエラーかもと思い、
こちらに投稿させていただきました。

当サイトで登録済のウェブユーザについてパスワードを変更したところ、
管理画面上で下記のようなPHPエラーが表示されます。
(適宜伏せてあります)

また、パスワードの変更そのものは完了したようですが、
ログイン後に正常な画面が表示されません。
(恐らくこちらの設定による404扱いでトップページが表示されます)

不明な点や不具合がありましたら
ご指摘よろしくお願いいたします。

« PHP Parse Error »
PHP error debug
Error : Use of undefined constant user_groups - assumed 'user_groups' (this will throw an Error in a future version of PHP)
ErrorType[num] : WARNING[2]
File : /home/○/www/manager/processors/permission/save_web_user.processor.php
Line : 341
Source : if (user_groups) {
LastQuery : DELETE FROM `○_modx`.`modx_web_groups` WHERE webuser='3'
Basic info
REQUEST_URI : /manager/index.php?a=89
Manager action : 89 - Saving web user
Referer : http://○/manager/index.php?a=88&id=3
User Agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.100 Safari/537.36
IP : ○.○.○.○
Benchmarks
MySQL : 0.1324 s (13 Requests)
PHP : 0.0953 s
Total : 0.2277 s
Memory : 2.4 MB

Backtrace

1 include_once()
manager/index.php on line 252
アバター
yama
管理人
記事: 3073
登録日時: 2009年7月29日(水) 02:50

リソースのグループ管理がうまく機能しません

投稿記事by yama » 2019年8月21日(水) 08:33

https://github.com/modxcms-jp/evolution ... evelop.zip
修正しました。確認をお願いしてよいでしょうか?
1.0.22Jであればmanagerフォルダを上書きするだけで確認できます。
shiokari
メンバー
メンバー
記事: 29
登録日時: 2014年7月18日(金) 20:50

リソースのグループ管理がうまく機能しません

投稿記事by shiokari » 2019年8月21日(水) 17:10

yama様

早速ご対応いただき、誠にありがとうございます。
また、トピックを分けていただきお手数をおかけしました。

いただいたmanagerフォルダを上書きしたところ、
下記のPHPエラーが発生してリソースの更新ができない状況です。

度々お手数をおかけして申し訳ございません。
何か情報の不足や不備がありましたら、ご指摘いただければ幸いです。
何卒よろしくお願い申し上げます。

« MODX Parse Error »
MODX encountered the following error while attempting to parse the requested resource:
« PHP Parse Error »
PHP error debug
Error : min(): Array must contain at least one element
ErrorType[num] : WARNING[2]
File : /home/○/www/manager/includes/cache_sync.class.php
Line : 295
Source : $min = min($time);
LastQuery : SELECT MIN(pub_date) AS result FROM `○_modx`.`modx_site_revision` WHERE 0 < pub_date AND status = 'standby' AND UNIX_TIMESTAMP()<pub_date
Basic info
REQUEST_URI : /manager/index.php
Manager action : 5 - Saving resource
Referer : http://○/manager/index.php?id=128&a=27
User Agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.100 Safari/537.36
IP : ○.○.○.○
Benchmarks
MySQL : 0.0365 s (28 Requests)
PHP : 0.0950 s
Total : 0.1316 s
Memory : 2.4 MB

Backtrace

1 include_once()
manager/index.php on line 225
2 $modx->__call()
manager/processors/document/save_resource.processor.php on line 136
3 SubParser->clearCache()
manager/includes/document.parser.class.inc.php on line 103
4 synccache->emptyCache()
manager/includes/extenders/ex_subparser.php on line 241
5 synccache->publishBasicConfig()
manager/includes/cache_sync.class.php on line 89
6 synccache->getCacheRefreshTime()
manager/includes/cache_sync.class.php on line 202
7 min()
manager/includes/cache_sync.class.php on line 295
systemnoah
メンバー
メンバー
記事: 1
登録日時: 2019年8月27日(火) 14:40

リソースのグループ管理がうまく機能しません

投稿記事by systemnoah » 2019年8月27日(火) 14:57

------------------------
ヘテムル レンタルサーバ
MySQLのバージョン 5.6.23-log
文字コード utf8_general_ci
PHP Version    7.1.14
MODXバージョン 1.0.22J
------------------------

Yama様

こちらに記述で良かったでしょうか?
間違ってたら申し訳ございません。

既に質問されており、重複となってしまいますが、同様のエラーが出て困っております。
「ユーザー管理>セキュリティ>許可するリソース」が、動作しなかったので(※最後に記載したリソースしか許可されません)、上記にあるmanagerを上書きしたところ、shiokari様と同じ状態となってしまいました。

現在は「manager」を戻し動いている状態なのですが、ユーザー毎権限分けが出来ません。

お忙しい所、申し訳なく思いますが何か対処方法があれば教えて頂けると助かります。
何卒よろしくお願いいたします。

↓↓グローバル設定更新時↓↓
≪ MODX Parse Error ≫
MODX encountered the following error while attempting to parse the requested resource:
≪ PHP Parse Error ≫
PHP error debug
Error : min(): Array must contain at least one element
ErrorType[num] : WARNING[2]
File : /home/users/~/manager/includes/cache_sync.class.php
Line : 295
Source : $min = min($time);
LastQuery : SELECT MIN(pub_date) AS result FROM `_●`.`modx_site_revision` WHERE 0 < pub_date AND status = 'standby' AND UNIX_TIMESTAMP()<pub_date
Basic info
REQUEST_URI : /●/manager/index.php
Referer : http://●/manager/index.php?a=17
User Agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.100 Safari/537.36
IP : ●.●.●.●
Benchmarks
MySQL : 0.0494 s (19 Requests)
PHP : 0.0334 s
Total : 0.0828 s
Memory : 2.48 MB
Backtrace
1 include_once()
manager/index.php on line 368
2 $modx->__call()
manager/processors/save_settings.processor.php on line 153
3 SubParser->clearCache()
manager/includes/document.parser.class.inc.php on line 103
4 synccache->emptyCache()
manager/includes/extenders/ex_subparser.php on line 241
5 synccache->publishBasicConfig()
manager/includes/cache_sync.class.php on line 89
6 synccache->getCacheRefreshTime()
manager/includes/cache_sync.class.php on line 202
7 min()
manager/includes/cache_sync.class.php on line 295
アバター
yama
管理人
記事: 3073
登録日時: 2009年7月29日(水) 02:50

リソースのグループ管理がうまく機能しません

投稿記事by yama » 2019年8月27日(火) 19:12

https://github.com/modxcms-jp/evolution ... evelop.zip
修正を加えましたので、再度試していただいてよいでしょうか?
shiokari
メンバー
メンバー
記事: 29
登録日時: 2014年7月18日(金) 20:50

リソースのグループ管理がうまく機能しません

投稿記事by shiokari » 2019年8月28日(水) 12:44

yama様

いつも大変お世話になっております。
いただいたファイルを上書きしましたが、エラーは変わらない模様です。
(manager/includes/cache_sync.class.phpの295行目)
不明な点や不具合がありましたら
恐れ入りますがご指摘よろしくお願いいたします。

« MODX Parse Error »
MODX encountered the following error while attempting to parse the requested resource:
« PHP Parse Error »
PHP error debug
Error : min(): Array must contain at least one element
ErrorType[num] : WARNING[2]
File : /home/○/www/manager/includes/cache_sync.class.php
Line : 295
Source : $min = min($time);
LastQuery : SELECT MIN(pub_date) AS result FROM `○_modx`.`modx_site_revision` WHERE 0 < pub_date AND status = 'standby' AND UNIX_TIMESTAMP()<pub_date
Basic info
REQUEST_URI : /manager/index.php
Manager action : 5 - Saving resource
Referer : http://○/manager/index.php?a=27&id=130
User Agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.132 Safari/537.36
IP : ○.○.○.○
Benchmarks
MySQL : 0.0427 s (35 Requests)
PHP : 0.1886 s
Total : 0.2313 s
Memory : 2.4 MB

Backtrace

1 include_once()
manager/index.php on line 225
2 $modx->__call()
manager/processors/document/save_resource.processor.php on line 136
3 SubParser->clearCache()
manager/includes/document.parser.class.inc.php on line 103
4 synccache->emptyCache()
manager/includes/extenders/ex_subparser.php on line 241
5 synccache->publishBasicConfig()
manager/includes/cache_sync.class.php on line 89
6 synccache->getCacheRefreshTime()
manager/includes/cache_sync.class.php on line 202
7 min()
manager/includes/cache_sync.class.php on line 295
アバター
yama
管理人
記事: 3073
登録日時: 2009年7月29日(水) 02:50

リソースのグループ管理がうまく機能しません

投稿記事by yama » 2019年8月28日(水) 14:25

cache_sync.class.zip
(4.32 KiB) ダウンロード数: 11 回

manager/includes/フォルダに上記のファイルを上書きして試してみていただけますでしょうか?
shiokari
メンバー
メンバー
記事: 29
登録日時: 2014年7月18日(金) 20:50

リソースのグループ管理がうまく機能しません

投稿記事by shiokari » 2019年8月28日(水) 16:55

yama様

お忙しいところ早速ご対応いただき、どうもありがとうございます。
おかげさまで、無事上記エラーが解消しました。

が、たびたびご面倒をおかけして申し訳ございません…
当方サイトではwebloginでログインした後にcfformmailerの入力フォームへ案内しているのですが

SYSTEM ERROR::Chunk read error

アップデート後に上記エラーが出て表示されなくなりました。
ちなみに管理画面にログインしている間は問題なく表示されます。

先刻、managerだけでなくassetsフォルダについても
日付が新しいファイルについては上書きしてしまったのが原因かもしれませんが
管理画面ではエラーログが表示されないため悩んでおります。

新しい記事にしたほうがよろしければ、その旨ご指摘いただければ幸いです。
どうぞよろしくお願いいたします。
アバター
yama
管理人
記事: 3073
登録日時: 2009年7月29日(水) 02:50

リソースのグループ管理がうまく機能しません

投稿記事by yama » 2019年8月28日(水) 17:07

cfFormMailerのバージョンは分かりますか?class.cfFormMailer.inc.phpというファイルの先頭のほうに
@version 1.6 というふうに書いてあると思います。

https://github.com/yama/cfFormMailer/archive/master.zip
もしよければ上記の最新版でアップデートしていただけますでしょうか?
ファイルを差し替えるだけでなく、snippet.cfFormMailer.phpの中身を
管理画面の cfFormMailerのテキストエリアに貼り付けて更新する必要があります。
同じエラーが出る場合は、もう少し詳細なエラーを得られるように調整を加えてみます。
shiokari
メンバー
メンバー
記事: 29
登録日時: 2014年7月18日(金) 20:50

リソースのグループ管理がうまく機能しません

投稿記事by shiokari » 2019年8月28日(水) 17:54

早速ありがとうございます。
cfFormMailerのバージョンは1.4でした。
アップデートしたところ、おかげさまで無事動作しました。
重ねてお礼申し上げます。

ところで、当サイトではチャンクで記述するテンプレート(tmpl_inputなど)に
リソースIDを割り当てておりましたが、
最新版でそのまま適用するとtpl read errorが発生しました。

数字だけではだめなのかと思い[~数字~]としてみましたが、やはり読み込まれないようです。
最新版ではこのような記述は不可でしょうか。
もし適切な記述方法がありましたら、教えていただければ幸いです。
どうぞよろしくお願いいたします。
アバター
yama
管理人
記事: 3073
登録日時: 2009年7月29日(水) 02:50

リソースのグループ管理がうまく機能しません

投稿記事by yama » 2019年8月28日(水) 19:10

「tpl read error」の後に続けてリソースIDが表示されるはずですが、表示されてますでしょうか?
shiokari
メンバー
メンバー
記事: 29
登録日時: 2014年7月18日(金) 20:50

リソースのグループ管理がうまく機能しません

投稿記事by shiokari » 2019年8月28日(水) 19:33

申し訳ありません、説明不足でした。
仰る通り、「tpl read error(id)」のように表示されました。
idの部分を[~id~]にしたら「tpl read error(pass/hoge.html)」のようになりました。
不明な点がありましたらご指摘ください。
アバター
yama
管理人
記事: 3073
登録日時: 2009年7月29日(水) 02:50

リソースのグループ管理がうまく機能しません

投稿記事by yama » 2019年8月28日(水) 19:44

class.cfFormMailer.inc.zip
(15.27 KiB) ダウンロード数: 9 回

上記ファイルを assets/snippets/cfFormMailer/ フォルダに上書きするとどうなるか試していただけますか?
shiokari
メンバー
メンバー
記事: 29
登録日時: 2014年7月18日(金) 20:50

リソースのグループ管理がうまく機能しません

投稿記事by shiokari » 2019年8月29日(木) 08:51

yama様

早速ご対応いただき、誠にありがとうございます。
おかげさまで無事動作しました。

何度もお手数をおかけして恐縮の極みですが
今後ともどうぞよろしくお願い申し上げます。
アバター
yama
管理人
記事: 3073
登録日時: 2009年7月29日(水) 02:50

リソースのグループ管理がうまく機能しません

投稿記事by yama » 2019年9月01日(日) 19:53

class.cfFormMailer.inc.zip
(15.27 KiB) ダウンロード数: 6 回

確認ありがとうございます。他にも気になる点がいくつかあって調整を加えましたので、
もしよければ上記のファイルをもう一度試していただいてよいでしょうか?
shiokari
メンバー
メンバー
記事: 29
登録日時: 2014年7月18日(金) 20:50

リソースのグループ管理がうまく機能しません

投稿記事by shiokari » 2019年9月02日(月) 10:24

色々とご対応いただきありがとうございます。
上書きしたところ、下記のエラーが表示されました。

Fatal error: Cannot redeclare evo() (previously declared in /home/○/www/assets/snippets/cfFormMailer/class.cfFormMailer.inc.php:2080) in /home/○/www/assets/snippets/cfFormMailer/class.cfFormMailer.inc.php on line 2086

不備がありましたら、恐れ入りますが
ご指摘よろしくお願いいたします。
アバター
yama
管理人
記事: 3073
登録日時: 2009年7月29日(水) 02:50

リソースのグループ管理がうまく機能しません

投稿記事by yama » 2019年9月02日(月) 10:28

class.cfFormMailer.inc.zip
(15.28 KiB) ダウンロード数: 6 回

すいません、単純ミスでした。修正しましたので上記のファイルを試していただいてよいでしょうか?
shiokari
メンバー
メンバー
記事: 29
登録日時: 2014年7月18日(金) 20:50

リソースのグループ管理がうまく機能しません  【解決済み】

投稿記事by shiokari » 2019年9月02日(月) 10:34

どうもありがとうございます。
おかげさまで、無事動作しました。
これくらいは自分でも気づくべきところ、お手数をおかけして申し訳ございません。

今後ともどうぞよろしくお願いいたします。