テンプレート、新規ユーザー編集でエラー  【解決済み】

質問全般・改善要望
mojira
メンバー
メンバー
記事: 83
登録日時: 2009年10月04日(日) 14:25

テンプレート、新規ユーザー編集でエラー  【解決済み】

投稿記事by mojira » 2014年6月02日(月) 23:39

MODXのバージョンを1.0.10Jから  1.0.12J-r1へアップした所、テンプレート編集や新規ユーザー追加時にエラーが
出てしまうようになりました。

http://goo.gl/NgNiQo
↑上記のパッチをあててみましたが、改善されませんでした。

テンプレート編集時のエラー内容は

コード: 全て選択

« MODX Parse Error »

MODX encountered the following error while attempting to parse the requested resource:
« Execution of a query to the database failed - Unknown column 'parent' in 'field list' »
SQL > UPDATE `XXXXXXXXXXXX`.`modx_site_templates` SET `templatename`='Minimal Template',`description`='Default minimal empty template',`content`='\r\n\r\n\r\n \r\n \r\n \r\n\r\n\r\n
[*pagetitle*]

\r\n [*content*] \r\n\r\n',`locked`='0',`category`='0',`parent`='' WHERE id='1'
Basic info
REQUEST_URI :   /manager/index.php
Manager action :   20 - Saving template
Referer :   http://XXXXXXXXXXXX/manager/index.php?id=1&a=16
User Agent :   Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.32 Safari/537.36
IP :   XXXXXXXXXXXX
Benchmarks
MySQL :   0.2234 s (3 Requests)
PHP :   0.0790 s
Total :   0.3024 s
Memory :   1.84 MB

Backtrace

1   include_once()
manager/index.php on line 348
2   DBAPI->update()
manager/processors/save_template.processor.php on line 123
3   DBAPI->query()
manager/includes/extenders/dbapi.mysql.class.inc.php on line 261



ユーザー追加編集時のエラーは

コード: 全て選択

« MODX Parse Error »

MODX encountered the following error while attempting to parse the requested resource:
« Execution of a query to the database failed - Unknown column 'street' in 'field list' »
SQL > INSERT INTO `XXXXXXXXXXX`.`modx_user_attributes` (internalKey,fullname,role,email,phone,mobilephone,fax,zip,street,city,state,country,gender,dob,photo,comment,blocked,blockeduntil,blockedafter) VALUES('3','','1','info@XXXXXXXXXXX.XXX','','','','','','','','','0','0','','','0','0','0')
Basic info
REQUEST_URI :   /manager/index.php?a=32
Manager action :   32 - Saving user
Referer :   http://XXXXXXXXXXX/manager/index.php?a=11
User Agent :   Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.32 Safari/537.36
IP :   114.155.207.245
Benchmarks
MySQL :   0.3166 s (6 Requests)
PHP :   0.0898 s
Total :   0.4065 s
Memory :   1.93 MB

Backtrace

1   include_once()
manager/index.php on line 309
2   DBAPI->insert()
manager/processors/save_user.processor.php on line 141
3   DBAPI->__insert()
manager/includes/extenders/dbapi.mysql.class.inc.php on line 270
4   DBAPI->query()
manager/includes/extenders/dbapi.mysql.class.inc.php on line 323


となります。

また、eformを使用していますが、フォームを使う度に

コード: 全て選択

phpmailer - イベントログ
 エラー
イベントID   0
ソース   phpmailer
日付   2014/06/02 23:15:55
Invalid address:


上記のエラーがログに残ります。
フォームの内容は正常に送受信できています。

1.0.12J-r1へバージョンアップしたのは、1ヶ月ほど前なのですが、テンプレートの編集などをしなかったので、エラーは今日まで気が付きませんでした。
1.0.12J-r1へバージョンアップ後に色々とリソースを追加しておりますが、1.0.10Jへ戻すことで治るのなら、戻したいのですが大丈夫でしょうか。
※バージョンアップ前のデータは残しております。

お忙しいところ申し訳ございませんが
どうぞ宜しくお願い申し上げます。

-----
ご利用のサーバ:ロリポップ!
MODXのバージョン: 1.0.12J-r1
PHPのバージョン:5.3.15
MySQLのバージョン:5.0.45
ブラウザ:chrome
-----
アバター
yama
管理人
記事: 2915
登録日時: 2009年7月29日(水) 02:50

Re: テンプレート、新規ユーザー編集でエラー

投稿記事by yama » 2014年6月02日(月) 23:56

データベースの内容が先祖返りしているように思えます。
最新版は1.0.13J-r1ですが、お使いのバージョンは1.0.12J-r1でしょうか?
mojira
メンバー
メンバー
記事: 83
登録日時: 2009年10月04日(日) 14:25

Re: テンプレート、新規ユーザー編集でエラー

投稿記事by mojira » 2014年6月03日(火) 10:06

yamaさん いつもありがとうございます。

yama さんが書きました:データベースの内容が先祖返りしているように思えます。
最新版は1.0.13J-r1ですが、お使いのバージョンは1.0.12J-r1でしょうか?


1.0.13J-r1へのバージョンアップを考えていたのですが、その当時、不具合報告が複数フォーラムに投稿されていた為、
最新ではなく、1.0.12J-r1へバージョンアップしました。
※今なら1.0.13J-r1でアップしていたと思います。

●データベースの内容が先祖返りについて
データベースやプログラムには明るくないため、以下の様な解決方法を考えております。

全データ保存後にバージョンを1.0.10Jへ変更して、1.0.10J運用時のデータでリストア→1.0.13J-r1へアップする
、その後、1.0.12J-r1バージョンアップしたあとで追加した複数のリソースを改めて手入力する。

エラー再発の可能性もありますが、上記の方法を考えています。
yamaさんの知見をお聞かせ頂ければ幸いです。

どうぞ宜しくお願い申し上げます。
アバター
yama
管理人
記事: 2915
登録日時: 2009年7月29日(水) 02:50

Re: テンプレート、新規ユーザー編集でエラー

投稿記事by yama » 2014年6月03日(火) 10:20

1. site_content・site_tmplvar_access・site_tmplvar_contentvalues・site_tmplvar_templates・site_tmplvarsのSQLデータのみをバックアップ
2. 最新版(現時点で1.0.13J-r1)にアップデート
3. バックアップをとっておいたSQLデータを使ってコンテンツデータをリストア

上記の手順を試してみていただけますでしょうか
mojira
メンバー
メンバー
記事: 83
登録日時: 2009年10月04日(日) 14:25

Re: テンプレート、新規ユーザー編集でエラー

投稿記事by mojira » 2014年6月03日(火) 10:39

yamaさんへ

運用中のサイトなので、今夜遅い時間に試して,結果をご報告させて頂きます。

早々にご返信頂き助かります。
ありがとうございました。


yama さんが書きました:1. site_content・site_tmplvar_access・site_tmplvar_contentvalues・site_tmplvar_templates・site_tmplvarsのSQLデータのみをバックアップ
2. 最新版(現時点で1.0.13J-r1)にアップデート
3. バックアップをとっておいたSQLデータを使ってコンテンツデータをリストア

上記の手順を試してみていただけますでしょうか
mojira
メンバー
メンバー
記事: 83
登録日時: 2009年10月04日(日) 14:25

Re: テンプレート、新規ユーザー編集でエラー

投稿記事by mojira » 2014年6月04日(水) 03:09

yamaさんへ

教えて頂いた内容を試してみた結果、テンプレート編集やユーザー追加が出来るようになりました :D

1. site_content・site_tmplvar_access・site_tmplvar_contentvalues・site_tmplvar_templates・site_tmplvarsのSQLデータのみをバックアップ
2. 最新版(現時点で1.0.13J-r1)にアップデート
3. バックアップをとっておいたSQLデータを使ってコンテンツデータをリストア


ただ、eformのエラーは消えませんでした。
eformの記述方法に何か問題があるのかも知れません。
とりあえず、送受信は正常にできるので、これから時間をかけて精査してみたいと思います。

ありがとうございました!
アバター
yama
管理人
記事: 2915
登録日時: 2009年7月29日(水) 02:50

Re: テンプレート、新規ユーザー編集でエラー

投稿記事by yama » 2014年7月07日(月) 13:05

eFormの件忘れてました。調査して問題が見つかれば修正パッチを作成しますが、試していただいてよいでしょうか?
mojira
メンバー
メンバー
記事: 83
登録日時: 2009年10月04日(日) 14:25

Re: テンプレート、新規ユーザー編集でエラー

投稿記事by mojira » 2014年7月07日(月) 18:46

yama さんが書きました:eFormの件忘れてました。調査して問題が見つかれば修正パッチを作成しますが、試していただいてよいでしょうか?


yamaさん、いつもありがとうございます。

eform のエラー内容のログは

phpmailer - イベントログ
エラー
イベントID 14
ソース phpmailer
日付 2014/06/04 13:29:23
Invalid address:


こんな感じで、続いておりますが、何故か正常にメールの送受信はできていますので、今はエラーログを定期的に削除してしのいでいます。

修正パッチを作成の件、大変有りがたいのですが、多分当方の設定ミスだと思いますので、引き続き設定を変えて色々やってみたいと思います。

今のeformのタグは以下のような感じです。
&eformOnBeforeMailSent=`getServer` は迷惑メールが多いので、IPアドレスを表示させる為に付けています。

コード: 全て選択

[!getServer!]
[!eForm? &to=`XXX@XXXX.co.jp` &formid=`tokoform` &tpl=`TokoForm` &report=`tokoThanksRpt` &automessage=`ef_automsform` &thankyou=`tokoThanks` &sendAsHtml=`0` &vericode=`0` &eformOnBeforeMailSent=`getServer` !]


※添付ファイルはグローバル設定のメール送信方法部分です。

運営中のサイトなので、クライアントさんと連絡をとりながら、作業を進めますが、yama様でなにか、思い当たる所がありましたらご助言頂ければ幸いです。

お忙しいところ、ご連絡ありがとうございました。
添付ファイル
eform.png
アバター
yama
管理人
記事: 2915
登録日時: 2009年7月29日(水) 02:50

Re: テンプレート、新規ユーザー編集でエラー

投稿記事by yama » 2014年7月07日(月) 19:10

eform.inc.zip
(14.74 KiB) ダウンロード数: 234 回
添付のファイルを解凍してassets/snippets/eform/ディレクトリに上書きしてみていただけますでしょうか。無難なコードを一行追記しただけなので、副作用などはないと思います。
mojira
メンバー
メンバー
記事: 83
登録日時: 2009年10月04日(日) 14:25

Re: テンプレート、新規ユーザー編集でエラー

投稿記事by mojira » 2014年7月07日(月) 20:22

yama様へ

頂いたファイルを上書きしてみましたところ、フォームでのエラーがなくなりました!

いつもありがとうございます。m(_ _)m