最新版でアップデートできないように思いますが、、、、、  【解決済み】

質問全般・改善要望
nakahi
メンバー
メンバー
記事: 131
登録日時: 2010年8月04日(水) 20:23

最新版でアップデートできないように思いますが、、、、、

投稿記事by nakahi » 2019年1月05日(土) 00:26

新年早々申し訳ございませんが、12月末日にアップロードされている1.0.21Jですが、以下の状態で、アップデートできません。

Xserverを使用していますが、PHP7.2.6では、
”Warning: Use of undefined constant MODX_CORE_PATH - assumed 'MODX_CORE_PATH' (this will throw an Error in a future version of PHP) in /home/xxxxxxxx/xxxx.com/public_html/manager/includes/document.parser.class.inc.php on line 193

Warning: require_once(MODX_CORE_PATHextenders/ex_subparser.php): failed to open stream: No such file or directory in /home/xxxxxxxx/xxxx.com/public_html/manager/includes/document.parser.class.inc.php on line 193

Fatal error: require_once(): Failed opening required 'MODX_CORE_PATHextenders/ex_subparser.php' (include_path='.:/opt/php-7.2.6/data/pear') in /home/xxxxxxxx/xxxx.com/public_html/manager/includes/document.parser.class.inc.php on line 193”


PHP7.1.18では、
”Warning: require_once(MODX_CORE_PATHextenders/ex_subparser.php): failed to open stream: No such file or directory in /home/xxxxxxxx/xxxx.com/public_html/manager/includes/document.parser.class.inc.php on line 193

Fatal error: require_once(): Failed opening required 'MODX_CORE_PATHextenders/ex_subparser.php' (include_path='.:/opt/php-7.1.18/data/pear') in /home/xxxxxxxx/xxxx.com/public_html/manager/includes/document.parser.class.inc.php on line 193”


PHP7.0.30では、
”Warning: require_once(MODX_CORE_PATHextenders/ex_subparser.php): failed to open stream: No such file or directory in /home/xxxxxxxx/xxxx.com/public_html/manager/includes/document.parser.class.inc.php on line 193

Fatal error: require_once(): Failed opening required 'MODX_CORE_PATHextenders/ex_subparser.php' (include_path='.:/opt/php-7.0.30/data/pear') in /home/xxxxxxxx/xxxx.com/public_html/manager/includes/document.parser.class.inc.php on line 193”


PHP5.6.36では、
”Warning: require_once(MODX_CORE_PATHextenders/ex_subparser.php): failed to open stream: No such file or directory in /home/xxxxxxxx/xxxx.com/public_html/manager/includes/document.parser.class.inc.php on line 193

Fatal error: require_once(): Failed opening required 'MODX_CORE_PATHextenders/ex_subparser.php' (include_path='.:/opt/php-5.6.36/data/pear') in /home/xxxxxxxx/xxxx.com/public_html/manager/includes/document.parser.class.inc.php on line 193”

となり、PHP5.6.36でもエラーが出ます。
どのようにすればよろしいのでしょうか?宜しくお願い申し上げます。
アバター
yama
管理人
記事: 3058
登録日時: 2009年7月29日(水) 02:50

最新版でアップデートできないように思いますが、、、、、

投稿記事by yama » 2019年1月05日(土) 09:48

https://github.com/modxcms-jp/evolution ... evelop.zip
こちらでは症状を確認できませんでしたが、念のための調整を加えてみました。
こちらを試していただいてよいでしょうか?
nakahi
メンバー
メンバー
記事: 131
登録日時: 2010年8月04日(水) 20:23

最新版でアップデートできないように思いますが、、、、、

投稿記事by nakahi » 2019年1月05日(土) 11:55

yamaさま、いつもお世話になっております。

記載のパッケージでは、インストールできました!

しかし、PHP7.2.6、PHP7.0.30では、
インストール後の「更新」ボタンをクリックすると、ローダーも回らず画面が固まったままになり、
ブラウザを更新で、また同じ画面が出て「更新」ボタンをクリックすると固まります。

PHP5.6.36では、
ダッシュボードの「更新」ボタンが表示されず、更新できません。
「グローバル設定」からの更新だけになります。

PHPのバージョンには関係なくサイトは表示されるようになりました。

以上のような状態ですが、私固有の問題のようでお手数をおかけいたします。
申し訳ございません。
アバター
yama
管理人
記事: 3058
登録日時: 2009年7月29日(水) 02:50

最新版でアップデートできないように思いますが、、、、、

投稿記事by yama » 2019年1月05日(土) 12:23

DB内のバージョン情報が更新されると「更新」が表示されないようになっています。
おそらくそのためではないかな?という気もします。
エックスサーバーということなのでWAFは関係ないでしょうか?(今からは試せないと思いますが、、)
nakahi
メンバー
メンバー
記事: 131
登録日時: 2010年8月04日(水) 20:23

最新版でアップデートできないように思いますが、、、、、

投稿記事by nakahi » 2019年1月05日(土) 12:56

度々ありがとうございます。
yama さんが書きました:Source of the post エックスサーバーということなのでWAFは関係ないでしょうか?

WAFの設定ですが、
XSS、SQL、ファイル、メール、コマンド、PHP、
すべて、OFFの状態で使用しています。

PHP7.2.6で動作させていますが、左のツリー画面のアイコンが表示されずに、「クリックするとコンテキストメニュー リソース名」となっています。
リソース名が横スクロールをしないと出てきません。

また、ダッシュボードの「サブリソース一覧」をクリックするとエラーが出ます。

イベントログのエラーの内容は、

ソース Parser - extract($_style); - Viewing Resourc
日付 2019/01/05 12:44:01
ユーザー xxxxx
« MODX Parse Error »
MODX encountered the following error while attempting to parse the requested resource:
« PHP Parse Error »
PHP error debug
Error : extract() expects parameter 1 to be array, null given
ErrorType[num] : WARNING[2]
File : /home/xxxxxx/xxx.com/public_html/manager/actions/document/resources_list.static.php
Line : 464
Source : extract($_style);
LastQuery : SELECT DISTINCT sc.*,MAX(IF(sc.privatemgr=0 , 1, 0)) as has_access,rev.status FROM `xxxxxxxx`.`modx_site_content` sc LEFT JOIN `xxxxxxxx`.`modx_document_groups` dg ON dg.document=sc.id LEFT JOIN `xxxxxxxx`.`modx_site_revision` rev on rev.elmid=sc.id AND (rev.status='draft' OR rev.status='pending' OR rev.status='standby') AND rev.element='resource' WHERE sc.parent='0' AND (sc.privatemgr=0 ) GROUP BY sc.id,rev.status ORDER BY sc.isfolder DESC, sc.published ASC, sc.publishedon DESC, if(sc.editedon=0,10000000000,sc.editedon) DESC, sc.id DESC LIMIT 0,20
Basic info
REQUEST_URI : /manager/index.php?a=120
Manager action : 120 - Viewing Resources List
Referer : https://xxx.com/manager/index.php?a=2
User Agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36 OPR/57.0.3098.106
IP : 106.73.67.32
Benchmarks
MySQL : 0.0077 s (7 Requests)
PHP : 0.0036 s
Total : 0.0113 s
Memory : 742.63 KB

Backtrace

1 include_once()
manager/index.php on line 217
2 getContextMenu()
manager/actions/document/resources_list.static.php on line 131
3 extract()
manager/actions/document/resources_list.static.php on line 464
アバター
yama
管理人
記事: 3058
登録日時: 2009年7月29日(水) 02:50

最新版でアップデートできないように思いますが、、、、、

投稿記事by yama » 2019年1月05日(土) 14:10

さっきのもそうですが、そのへんは今回の改修とは全く関係ない部分です。
MODXの管理画面は3ペイン構造になっていて、ツリーペインだけ$_styleを
読み込めていないというのも気になります。
念のため、もう一度managerフォルダを上書きしてみていただけますでしょうか?
PHPパースエラーが起きているわけでもないので、特定のファイルが中途半端に
転送されているということはなさそうですが、、
nakahi
メンバー
メンバー
記事: 131
登録日時: 2010年8月04日(水) 20:23

最新版でアップデートできないように思いますが、、、、、  【解決済み】

投稿記事by nakahi » 2019年1月05日(土) 14:45

yama さんが書きました:Source of the post 念のため、もう一度managerフォルダを上書きしてみていただけますでしょうか?

yamaさま、さんざんお騒がせいたしました。
上書きで、1.0.22J-beta1の正常運転になりました!
明らかに固有の出来事だったようで申し訳ございませんでした。
確認後、別サイトも同じようにアップデートしましたが、PHP7.2.6で、全く問題なく一発でアップデートできました。
一体何だったのかという疑問が残りますが、ご推察どおりmanagerフォルダがきれいに上書きできていなかったのでしょう。
Filezillaで今まで問題がなかったのですが・・・・
ともかく無事完了いたしました。新年早々本当に申し訳ございませんでした。
有難うございました。次回からは何度か上書きをして確認したいと思います。
アバター
yama
管理人
記事: 3058
登録日時: 2009年7月29日(水) 02:50

最新版でアップデートできないように思いますが、、、、、

投稿記事by yama » 2019年1月05日(土) 15:43

FileZillaの場合は転送キューペインの「失敗した転送」タブを確認すると分かります。
今回はツリーペインの問題は解決できたようですが、他のファイルの転送に失敗している
可能性があるので、念のためもう一度managerフォルダと、assetsフォルダも上書き
転送しておくとよいかもです。転送失敗が表示されてなければokです。
nakahi
メンバー
メンバー
記事: 131
登録日時: 2010年8月04日(水) 20:23

最新版でアップデートできないように思いますが、、、、、

投稿記事by nakahi » 2019年1月05日(土) 16:07

managerフォルダと、assetsフォルダを上書きしておきました!
順調です!
本当に度々有難うございました!