ページ 11

PHP7.2にアップ後エラー

Posted: 2018年10月08日(月) 21:24
by masco
PHPを7.2.6にしたところ下記のエラーが出ました。

session_cache_limiter(): Cannot change cache limiter when session is active in /***/public_html/manager/includes/initialize.functions.inc on line 46

githubからダウンロードした1.0.20J の最新版です。

よろしくお願いいたします。

PHP7.2にアップ後エラー

Posted: 2018年12月30日(日) 18:35
by yama
フォーラムの確認が遅くなりましたが、正式リリースのためこちら調査中です。

https://github.com/modxcms-jp/evolution ... evelop.zip
こちらのパッケージでは解決できてなかったでしょうか?

2018-12-30.png

こちらではPHP7.2.6で動作確認できています。

PHP7.2にアップ後エラー

Posted: 2018年12月30日(日) 19:04
by masco
yamaさま

ありがとうございます。
更新しましたが、まだ現れます。

管理画面側ではエラーが出ていないのですが、
フロントエンド側で表示されます。

サーバーは下記のものを使っています。
スターサーバー
OS Linux 4.4.0-137-generic #163-Ubuntu SMP Mon Sep 24 13:14:43 UTC 2018 x86_64
ウェブサーバー nginx
PHPのバージョン 7.2.6(エラーが出るので現在は7.1.18)
MySQLのバージョン 5.7.16

PHP7.2にアップ後エラー

Posted: 2018年12月30日(日) 19:06
by masco
すみません、試しにchacheディレクトリの中身を削除したら表示が消えました。

PHP7.2にアップ後エラー

Posted: 2018年12月30日(日) 19:27
by yama
そうなんですね。原因が気になりますが、たぶんconfigなどのキャッシュを読み込んだ後に何か問題が起きていたのではと思います。
こういう場合、index.phpの先頭あたりに error_reporting(E_ALL & ~E_NOTICE); を記述すると
発生している問題をエラー表示できるようになります。セキュリティ上の理由でPHP7以降はこういった情報を
基本的には出力しない方針になったのですが、問題が発生した時にヒントを得られず困るので、もしまた問題が
起きたら試してみてください。