「1.0.18J」から「1.0.19J」へアップデートすると「テンプレート」と「スニペット」で内容変更できなくなってしまいました  【解決済み】

質問全般・改善要望
Kenny
メンバー
メンバー
記事: 160
登録日時: 2011年5月28日(土) 13:41

「1.0.18J」から「1.0.19J」へアップデートすると「テンプレート」と「スニペット」で内容変更できなくなってしまいました

投稿記事by Kenny » 2017年11月22日(水) 11:08

MODXバージョン 1.0.19J
PHPのバージョン 7.1.2
データベースのバージョン 5.6.23-log

お世話になります。

「1.0.18J」から「1.0.19J」へアップデートしたのですが、「テンプレート」と「スニペット」で、内容を変更し、更新ボタンを押すと「403 error」が出て、更新できなくなってしまいました。

他に変更点としてhttpからhttpsにしたのですが、「グローバル設定」の「サーバータイプ」でhttpsにしてあります。

初めてのパターンで、問題点が分からず困っております。。
アバター
yama
管理人
記事: 2929
登録日時: 2009年7月29日(水) 02:50

「1.0.18J」から「1.0.19J」へアップデートすると「テンプレート」と「スニペット」で内容変更できなくなってしまいました  【解決済み】

投稿記事by yama » 2017年11月22日(水) 11:29

https://www.google.com/search?q=modx+403
403というとサーバ側に原因があることが多いです。サーバは何をお使いですか?
WAFが関係しているとしたら、1.0.19Jの投稿処理のパターンがWAF側に登録されている多数のパターンのうちのひとつとたまたま似てしまったというだけで、システム自体に何か問題があるということではないので、WAF側で「これは無害」と指定する必要があります。
Kenny
メンバー
メンバー
記事: 160
登録日時: 2011年5月28日(土) 13:41

「1.0.18J」から「1.0.19J」へアップデートすると「テンプレート」と「スニペット」で内容変更できなくなってしまいました

投稿記事by Kenny » 2017年11月22日(水) 13:17

Yama様

いつも有難うございます!

おっしゃるとおりで、WAFが噛んでいました。
同時に移転した他のサイトは大丈夫だったので、混乱し、久々にびっくりしてしまいました…
有難うございました!