リソースを更新するとエラーが出ます

質問全般・改善要望
kachio
メンバー
メンバー
記事: 8
登録日時: 2015年7月23日(木) 15:46

リソースを更新するとエラーが出ます

投稿記事by kachio » 2017年9月19日(火) 09:53

お世話になっております。
過去ログ等にも同じような現象の方は見受けられないように思うので、質問させていただきます。

現在、ロリポップサーバーにて、MODX Evolution 1.0.19Jを使用して、サイト構築を行っております。
サイト作成からしばらくは通常通り使用できていたのですが、
ある時から、リソースの「更新」ボタンを押すと、エラーが表示されるようになりました。
ただ、エラーは表示されるのですが、もう一度リソースの編集画面を開くと、修正内容はいつも反映されています。

エラーの内容としては、下記URLに画面キャプチャを載せています。
https://drive.google.com/open?id=0B_zI8 ... mFiY1lRTHM
※画面が途中で切れているように見えますが、表示されているエラーメッセージはこれですべてです。
cache関係のファイルだと思うのですが、具体的に何が引っかかっているのかがわかりません。

テンプレートの違うものや、ファイルタイプの違うリソースに変えてみても、もれなくすべてのリソースで起こります。
また、MODX本体の再インストールは何度か試しましたが、効果は特にありませんでした。

何か原因は分かりますでしょうか。
よろしくお願い致します。

-----
利用のサーバ:
MODXのバージョン: 1.0.19J
PHPのバージョン: 5.2.17
MySQLのバージョン: 5.1.73
ブラウザ: Google Chrome
ホスティング会社:ロリポップサーバー ライトプラン
-----
アバター
yama
管理人
記事: 2911
登録日時: 2009年7月29日(水) 02:50

リソースを更新するとエラーが出ます

投稿記事by yama » 2017年9月19日(火) 12:48

報告ありがとうございます、後ほど修正します
アバター
yama
管理人
記事: 2911
登録日時: 2009年7月29日(水) 02:50

リソースを更新するとエラーが出ます

投稿記事by yama » 2017年9月19日(火) 21:44

https://github.com/modxcms-jp/evolution ... evelop.zip
修正しました。こちらのパッケージでアップデートしていただいてよいでしょうか?
http://modx.jp/docs/update.html
アップデート方法
kachio
メンバー
メンバー
記事: 8
登録日時: 2015年7月23日(木) 15:46

リソースを更新するとエラーが出ます

投稿記事by kachio » 2017年9月20日(水) 09:59

yamaさん

迅速なご対応、感謝します。
只今、アップデートしましたら、リソース更新時の症状がなくなりました。
ですが、今度はエレメント関係を更新した場合に別のエラーが出てしまいました。
テンプレート・テンプレート変数・チャンク・スニペット・プラグイン、すべてでエラーが出ます。

エラー画面のキャプチャ画像です。
https://drive.google.com/open?id=0B_zI8 ... Xo1dXNrLWs

お手数をおかけしますが、こちらもご対応お願いできないでしょうか…。
宜しくお願い致します。
アバター
yama
管理人
記事: 2911
登録日時: 2009年7月29日(水) 02:50

リソースを更新するとエラーが出ます

投稿記事by yama » 2017年9月20日(水) 21:54

https://github.com/modxcms-jp/evolution ... evelop.zip
修正しました。上記パッケージをダウンロードしてmanager/includes/ フォルダを上書きしていただけますでしょうか?
(全部上書きしていただいてもいいですが)
kachio
メンバー
メンバー
記事: 8
登録日時: 2015年7月23日(木) 15:46

リソースを更新するとエラーが出ます

投稿記事by kachio » 2017年9月21日(木) 09:09

yamaさん

ご対応ありがとうございます!
manager/includes/フォルダを上書きしましたら、エラーが出なくなりました!
リソースの更新の方も引き続き、無事に行えています。

とても助かりました。
ありがとうございました!
kachio
メンバー
メンバー
記事: 8
登録日時: 2015年7月23日(木) 15:46

リソースを更新するとエラーが出ます

投稿記事by kachio » 2017年9月21日(木) 10:31

何度もすみません。

上記のファイルを上書きして、無事にうまくいったと思っていたのですが、
サイトを表示させる際に、CSSが読み込まれなくなってしまいました。

症状としては、
CSS関係のリソースは開けるのですが、出力が真っ白(空)になっています。
HTMLやJavascriptは出力できており、CSSのみが出来ていない状態です。

最初はhtaccessやグローバル設定かなと思ったのですが、
1.0.19Jの初期のインストーラーで上書きすると上記症状が治り、
yamaさんにいただいたインストーラーで上書きすると再発しましたので、
今回の件の修正が絡んでいるのかな、と思った次第です。

すみませんが、もしこちらも原因がわかれば対処いただけないでしょうか。
重ね重ねお手数をおかけしますが、宜しくお願い致します。
アバター
yama
管理人
記事: 2911
登録日時: 2009年7月29日(水) 02:50

リソースを更新するとエラーが出ます

投稿記事by yama » 2017年9月21日(木) 10:32

了解です、後ほど修正します
アバター
yama
管理人
記事: 2911
登録日時: 2009年7月29日(水) 02:50

リソースを更新するとエラーが出ます

投稿記事by yama » 2017年9月21日(木) 19:46

手元の開発環境で試してみましたが、再現できませんでした。
http://170921194216-4188.evo.demo.modx.jp/manager/
このような構成になっているということで合ってますか?
kachio
メンバー
メンバー
記事: 8
登録日時: 2015年7月23日(木) 15:46

リソースを更新するとエラーが出ます

投稿記事by kachio » 2017年9月21日(木) 20:17

yamaさん、ありがとうございます。

デモサイトの中を見ながら、色々比較して構成を見ていたのですが、

CSSファイル内の先頭に記述していた

コード: 全て選択

@charset "utf-8";

を削除したら、きちんと出力されるようになりました…。
お手数かけてしまって大変申し訳ありません…。

@で始まるコードなので、binding関連の何かと干渉していたのでしょうか?
今まではいけてたんですが…。
熟練されてる方からすればケアレスミスみたいなものなのでしょうか…。
本当に申し訳ありません。

どうもありがとうございました。
アバター
yama
管理人
記事: 2911
登録日時: 2009年7月29日(水) 02:50

リソースを更新するとエラーが出ます

投稿記事by yama » 2017年9月21日(木) 20:44

なるほど原因が分かりました

コード: 全て選択

@URL:http://www.yahoo.co.jp

テンプレートを無効にしたリソースの先頭に上記のように書くと他のサイトのコンテンツを引っ張ってくることができるようになっているのですが、これが干渉しているようです。後ほど修正します。
(この仕様は実験的なものなので、正式リリースの時点では採用しないかもしれません)
アバター
yama
管理人
記事: 2911
登録日時: 2009年7月29日(水) 02:50

リソースを更新するとエラーが出ます

投稿記事by yama » 2017年9月21日(木) 21:37

https://github.com/modxcms-jp/evolution ... evelop.zip
修正しました。上記パッケージをダウンロードしてmanager/includes/ フォルダを上書きしていただけますでしょうか?
kachio
メンバー
メンバー
記事: 8
登録日時: 2015年7月23日(木) 15:46

リソースを更新するとエラーが出ます

投稿記事by kachio » 2017年9月21日(木) 21:45

yamaさん、ありがとうございます。

只今、ファイルを上書きしましたら、
無事に@charsetの記述有りでも出力されました!

丁寧なお仕事ぶりにいつも陰ながら感謝しております。
ありがとうございました!