下書きを採用しようとすると「unvalid token」と表示される。  【解決済み】

質問全般・改善要望
isoppa
メンバー
メンバー
記事: 8
登録日時: 2017年9月04日(月) 19:38

下書きを採用しようとすると「unvalid token」と表示される。

投稿記事by isoppa » 2017年9月04日(月) 20:10

MODX :1.0.19J
PHP:5.3.3
DB:MySQL 5.1.73

はじめまして

下書き機能について以下の手順を行ったところ、「unvalid token」と表示され、下書きを採用することができません。
1.コンテンツ編集画面で下書きを作成 ・・・・ 成功
2.下書きを編集し保存 ・・・・ 成功
3.コンテンツの編集画面で下書きを開く ・・・・ 成功
4.下書きの編集画面で「下書きを採用」を選び「更新」をクリック ・・・・ 成功
5.「今すぐ採用する」を選び「採用する」をクリック ・・・・ 「unvalid token」と表示される
6.コンテンツの編集画面を開く ・・・・ 下書きが採用されてない

イベントログや Apache のログ等にエラー等を確認することができません。

考えられる要因としては、次の3つがあります。
・MODxのバージョンを1.0.8Jから1.0.19Jにアップグレードしたこと
・PHPのバージョンが低いこと
・MySQLのバージョンが低いこと

何か対応策がありますでしょうか。
お手数をおかけしますがよろしくお願い致します。
アバター
yama
管理人
記事: 2916
登録日時: 2009年7月29日(水) 02:50

下書きを採用しようとすると「unvalid token」と表示される。

投稿記事by yama » 2017年9月04日(月) 20:59

https://github.com/modxcms-jp/evolution ... 9db336d462
修正しました
https://github.com/modxcms-jp/evolution ... evelop.zip
上記パッケージでアップデートしていただいてよいでしょうか?
isoppa
メンバー
メンバー
記事: 8
登録日時: 2017年9月04日(月) 19:38

下書きを採用しようとすると「unvalid token」と表示される。

投稿記事by isoppa » 2017年9月04日(月) 21:32

yama 様

早速の対応ありがとうございます。
添付頂いたパッケージでアップデートしたところ、無事に動作を致しました。
isoppa
メンバー
メンバー
記事: 8
登録日時: 2017年9月04日(月) 19:38

下書きを採用しようとすると「unvalid token」と表示される。  【解決済み】

投稿記事by isoppa » 2017年9月06日(水) 13:28

「プレビューボタンをクリックすると「can not preview」と表示される (viewtopic.php?f=32&t=1787) 」の yama 様いただいた返信で開発版ではすでに解決済みだということでしたので、以下のパッケージを用いたところ、この症状が発生しないことを確認させていただきました。
yama さんが書きました:Source of the post もしかするとtokenエラーの件は1.0.19J固有の不具合で、1.0.20J相当の開発版ではすでに解決していたのかもしれません。該当箇所の仮修正部分をまた元に戻してみましたので、
https://github.com/modxcms-jp/evolution ... evelop.zip
再びアップデートを試していただけますでしょうか。同様の不具合がまた戻ったらやっぱり直っていないものとして修正します。こちらでは問題が起きないことを確認済みです。

あと、グローバル設定「セキュリティ」タブの「PHPエラーの検出レベル」を「全てのエラーを検出する」にしてあるのではないでしょうか?プログラミングを多少理解できる場合はこの設定で細部まで丁寧にサイトを作るのがよいですが、現実的にはほとんど問題ない処理もチェックしますので、慣れないと扱いが難しいです。初期設定の「通知レベルの軽度の警告を無視する」あたりがちょうどいいと思います。WordPressなど多くの有名CMSはそのようになっています。
開発者としては、全てのエラーを検出する設定で見つかった不具合を今回のように報告いただけると助かります。