とあるテンプレートで左ツリーからリソースを選択・編集した場合、requireが利かない症状  【解決済み】

質問全般・改善要望
Kenny
メンバー
メンバー
記事: 160
登録日時: 2011年5月28日(土) 13:41

とあるテンプレートで左ツリーからリソースを選択・編集した場合、requireが利かない症状

投稿記事by Kenny » 2017年7月07日(金) 13:13

MODXバージョン 1.0.19J
PHPのバージョン 7.1.2
データベースのバージョン 5.6.23-log

たびたびお世話になります。

とあるテンプレートで、Quickmanger経由からのリソース編集はmanagermanagerのrequireが利くのに、左ツリーからリソースを選択・編集した場合はrequireが利かない症状が出ています。

他のテンプレートでは問題なく作動しているのですが、原因として何が考えられるでしょうか。

どうぞよろしくお願い致します。
Kenny
メンバー
メンバー
記事: 160
登録日時: 2011年5月28日(土) 13:41

とあるテンプレートで左ツリーからリソースを選択・編集した場合、requireが利かない症状  【解決済み】

投稿記事by Kenny » 2017年7月13日(木) 18:32

自己解決しましたのでご報告します。

テンプレート変数の中でjqueryによるオートコンプリート機能を入れており、そのjqueryとのバッティングでrequireが利かなかった模様です。
jqueryを使わないオートコンプリートを使用し解決しました。
かつ、マルチテキストも作動していなかったのですが、そちらも正常に戻りました。

どうぞご参考にしてください。