[1.0.15J] AjaxSearchのエラー【解決済み】

質問全般・改善要望
ifactory
メンバー
メンバー
記事: 16
登録日時: 2013年10月16日(水) 16:49

[1.0.15J] AjaxSearchのエラー【解決済み】

投稿記事by ifactory » 2016年2月17日(水) 20:08

お世話になります。

「1.0.14J-r9」より「1.0.15J」にアップデートしましたところ、AjaxSearchのエラーが発生したので、
デモサイトにてAjaxSearchだけ入れて試してみましたところ同様のエラーが発生いたしました。

Modx 1.0.15J
AjaxSearch 1.10.1

デモサイト
http://160217193701-8408.evo.demo.modx.jp/
管理画面
http://160217193701-8408.evo.demo.modx.jp/manager/
MODX管理者ユーザ
modx
MODX管理者パスワード
modx

どうぞよろしくお願いいたします。



« MODX Parse Error »

MODX encountered the following error while attempting to parse the requested resource:
« PHP Parse Error »
PHP error debug
Error : Missing argument 2 for SubParser::regClientStartupScript()
ErrorType[num] : WARNING[2]
File : /home/demo/html/160217193701-8408/manager/includes/extenders/ex_subparser.php
Line : 842
Source : function regClientStartupScript($src, $options)
Basic info
REQUEST_URI : /
Resource : [1]Home
Current Snippet : ajaxSearch
Referer : http://160217193701-8408.evo.demo.modx. ... =1&r=1
User Agent : Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_4) AppleWebKit/601.5.13 (KHTML, like Gecko) Version/9.1 Safari/601.5.13
IP : 127.0.0.2
Benchmarks
MySQL : 0.0039 s (9 Requests)
PHP : 0.0420 s
Total : 0.0459 s
Memory : 4.45 MB

Backtrace

1 $modx->executeParser()
index.php on line 119
2 $modx->prepareResponse()
manager/includes/document.parser.class.inc.php on line 377
3 $modx->outputContent()
manager/includes/document.parser.class.inc.php on line 571
4 $modx->parseDocumentSource()
manager/includes/document.parser.class.inc.php on line 602
5 $modx->evalSnippets()
manager/includes/document.parser.class.inc.php on line 2289
6 $modx->_get_snip_result()
manager/includes/document.parser.class.inc.php on line 1811
7 $modx->evalSnippet()
manager/includes/document.parser.class.inc.php on line 1869
8 eval()
manager/includes/document.parser.class.inc.php on line 1763
9 require()
manager/includes/document.parser.class.inc.php(1763) : eval()'d code on line 18
10 AjaxSearch->run()
assets/snippets/ajaxSearch/snippet.ajaxSearch.php on line 409
11 AjaxSearchCtrl->run()
assets/snippets/ajaxSearch/classes/ajaxSearch.class.inc.php on line 99
12 AjaxSearchOutput->setAjaxSearchHeader()
assets/snippets/ajaxSearch/classes/ajaxSearchCtrl.class.inc.php on line 73
13 $modx->regClientStartupScript()
assets/snippets/ajaxSearch/classes/ajaxSearchOutput.class.inc.php on line 907
14 $modx->__call()
assets/snippets/ajaxSearch/classes/ajaxSearchOutput.class.inc.php on line 907
15 call_user_func_array()
manager/includes/document.parser.class.inc.php on line 170
16 SubParser->regClientStartupScript()
on line
最後に編集したユーザー ifactory on 2016年2月23日(火) 13:58 [ 編集 1 回目 ]
ifactory
メンバー
メンバー
記事: 16
登録日時: 2013年10月16日(水) 16:49

1.0.15J AjaxSearchのエラー

投稿記事by ifactory » 2016年2月17日(水) 20:51

度々申し訳ありません。
今、試しにAjaxSearchを設置している別のサイト(1.0.14J-r9)を1.0.15Jにアップデートしたところ、
そちらは問題なく動いているので、こちらの設置方法に問題があるのかもしれません。
ちょっと違いを見てみます。

デモサイトの方は、設置後Homeに[!ajaxSearch!]とだけしております。
ifactory
メンバー
メンバー
記事: 16
登録日時: 2013年10月16日(水) 16:49

1.0.15J AjaxSearchのエラー

投稿記事by ifactory » 2016年2月17日(水) 23:32

見比べた所、問題なく動いていると思われた方のサイトは
ajaxSearch=`0`で動かしていたので大丈夫だったようです。

ajaxSearch=`1`だと、先のエラーになってしまうようです。
デモサイトでも、確認いたしました。

お手数をお掛けいたしますが、どうぞよろしくお願いいたします。
アバター
yama
管理人
記事: 2846
登録日時: 2009年7月29日(水) 02:50

1.0.15J AjaxSearchのエラー

投稿記事by yama » 2016年2月18日(木) 08:28

ありがとうございます。MODX本体側・AjaxSearch側の両方で簡単な修正が必要みたいです。後ほど修正します。
ifactory
メンバー
メンバー
記事: 16
登録日時: 2013年10月16日(水) 16:49

1.0.15J AjaxSearchのエラー

投稿記事by ifactory » 2016年2月19日(金) 18:43

ありがとうございます!
よろしくお願いいたします。
アバター
yama
管理人
記事: 2846
登録日時: 2009年7月29日(水) 02:50

1.0.15J AjaxSearchのエラー

投稿記事by yama » 2016年2月19日(金) 19:38

https://github.com/modxcms-jp/evolution ... d85525d2a4
https://github.com/modxcms/AjaxSearch/c ... 48ed42d0b0
上記、修正しました。

https://raw.githubusercontent.com/modxc ... parser.php
上記テキストを全選択して、
manager/includes/extenders/ex_subparser.php
上記ファイルとして上書き保存してください。

https://raw.githubusercontent.com/modxc ... hPopup.php
上記テキストを全選択して、
assets/snippets/ajasSearch/ajaxSearchPopup.php
上記ファイルとして上書き保存してください。
ifactory
メンバー
メンバー
記事: 16
登録日時: 2013年10月16日(水) 16:49

1.0.15J AjaxSearchのエラー

投稿記事by ifactory » 2016年2月23日(火) 13:57

先程、動作確認いたしました。
無事動いております。
早々に対応いただきありがとうございました。

“質問全般・改善要望” へ戻る