Evolution 1.0.14Jアップデートでサイトが表示されない  【解決済み】

質問全般・改善要望
nakahi
メンバー
メンバー
記事: 131
登録日時: 2010年8月04日(水) 20:23

Evolution 1.0.14Jアップデートでサイトが表示されない

投稿記事by nakahi » 2014年6月13日(金) 19:13

-----
ご利用のサーバ:エックスサーバー
MODXのバージョン:MODX Evolution 1.0.14J
PHPのバージョン:5.3.3
MySQLのバージョン:5.0.95
ブラウザ:FF
-----

いつもお世話になっています。

今回、MODX Evolution 1.0.14Jにアップデートしたところ、サイトが表示されなくなりました。

『ページの自動転送設定が正しくありません。
このアドレスへのリクエストに対するサーバの自動転送設定がループしています。
Cookie を無効化したり拒否していることにより、この問題が発生している可能性もあります。』

との表示が出ます。

アップデートする前のバージョンですが、「1.0.10J-r3」です。
他のバージョンは何の問題もありません。

これを解決するにはどのようにすれば宜しいのでしょうか。
何卒宜しくご教示お願い致します。
アバター
yama
管理人
記事: 3077
登録日時: 2009年7月29日(水) 02:50

Re: Evolution 1.0.14Jアップデートでサイトが表示されない

投稿記事by yama » 2014年6月13日(金) 20:26

インストールしているプラグインは分かりますか?(SEO Strict URLsなど)
nakahi
メンバー
メンバー
記事: 131
登録日時: 2010年8月04日(水) 20:23

Re: Evolution 1.0.14Jアップデートでサイトが表示されない

投稿記事by nakahi » 2014年6月13日(金) 21:18

yamaさん、いつもお世話になっています。

プラグインは以下のとおりです。

・Forgot Manager Login1.2b2
・ManagerManager0.4
・Quick Manager+1.5.5r7
・SEO Strict URLs1.0.1P4
・TransAlias1.0.1
・管理画面カスタマイズ1.0.3
・Search Highlight1.5
・SendPing3.2.0.1
・TinyMCE Rich Text Editor3.5.6
・Base URL Same Page Link Fix

宜しくお願い致します。
アバター
yama
管理人
記事: 3077
登録日時: 2009年7月29日(水) 02:50

Re: Evolution 1.0.14Jアップデートでサイトが表示されない

投稿記事by yama » 2014年6月13日(金) 22:32

https://github.com/yama/SEO_Strict_URLs ... master.zip
SEO Strict URLsを上記のものでアップデートしてください。それでもうまくいかなければ無効にしてみてください。

TinyMCEが3.5.6なのも気になります。MODXを1.0.14Jにアップデートすると3.5.11になるはずなので。
http://modx.jp/docs/update.html
こちらの手順でアップデートされてますでしょうか?ブラウザでinstall/ディレクトリにアクセスするとアップデータが起動します。

もし不要であればSearch Highlightも無効にしておいてください。(脆弱性に関して検証が十分にできていません)
nakahi
メンバー
メンバー
記事: 131
登録日時: 2010年8月04日(水) 20:23

Re: Evolution 1.0.14Jアップデートでサイトが表示されない  【解決済み】

投稿記事by nakahi » 2014年6月13日(金) 23:01

yama さんが書きました:https://github.com/yama/SEO_Strict_URLs/archive/master.zip
SEO Strict URLsを上記のものでアップデートしてください。それでもうまくいかなければ無効にしてみてください。

TinyMCEが3.5.6なのも気になります。MODXを1.0.14Jにアップデートすると3.5.11になるはずなので。
http://modx.jp/docs/update.html
こちらの手順でアップデートされてますでしょうか?ブラウザでinstall/ディレクトリにアクセスするとアップデータが起動します。

もし不要であればSearch Highlightも無効にしておいてください。(脆弱性に関して検証が十分にできていません)


yamaさん、早速ご丁寧に色々と有難うございました。

ご指摘の通り、SEO Strict URLsが原因でした。現状あまり必須ではないようなので、削除して上手く表示されました。

アップデートの手順は間違いないのですが、TinyMCEをアップデートしたサイトでは使わなくなったので、インストール時に入れなかったので
古いままでした・・・・・・・
で、削除しましたがSEO Strict URLsを削除した時点で解決しましたので、TinyMCEは影響がないようです。

Search Highlightも一緒に削除しました。

いつもの事ではございますが、早々に解決方法をご教示頂きまして本当にありがとうございました。
又宜しくお願い申し上げます。