AjaxSearchスニペット - リモートスクリプト実行の脆弱性とその対策

日本公式からのお知らせ
アバター
yama
管理人
記事: 2853
登録日時: 2009年7月29日(水) 02:50

AjaxSearchスニペット - リモートスクリプト実行の脆弱性とその対策

投稿記事by yama » 2014年6月07日(土) 11:04

【6月9日19時追記】

本件はMODX Evolution本体ではなくAjaxSearchスニペットの脆弱性であることが判明しました。MODXのバージョンや日本語版・英語版の違いに関係なく、AjaxSearchがインストールされている環境全てに脆弱性が存在します。


MODX Evolution 1.0.13 (and prior) AjaxSearch Vulnerability
http://forums.modx.com/thread/91266/
本家開発チームより、AjaxSearchの脆弱性についてアナウンスがありました。対策も同時に提示されていますので、取り急ぎ当フォーラムで告知いたします。

●対象バージョン
AjaxSearchスニペット 1.10.0以前(1.10.0含む)の全バージョン

●脆弱性の有無を判定する方法
assets/snippets/ajaxSearch/classes/ajaxSearch.class.inc.php
上記ファイルをテキストエディタで開くと、

コード: 全て選択

* Snippet: AjaxSearch
* -----------------------------------------------------------------------------
* @package  AjaxSearch
*
* @author       Coroico - www.evo.wangba.fr
* @version      1.10.0
* @date         27/03/2013

冒頭に上記のような記述があります。この場合はバージョンが1.10.0ということになります。

●対策方法
対策1 - AjaxSearchを利用していない場合
assets/snippets/ajaxSearch/ ディレクトリを削除することで脆弱性を解決できます。
またはMODX設置ディレクトリのindex-ajax.phpを削除してください。このファイルは、AjaxSearch以外で使われることはありません。

対策2 - AjaxSearchを利用している場合
対策済みのAjaxSearch最新版(日本語版1.10.1Jまたは本家版1.10.1)にアップデートします。(当トピックに添付)
対策済みのindex-ajax.phpをMODX設置ディレクトリに上書きすることでも脆弱性を解決できます。(当トピックに添付)

対策3 - 最も推奨する方法
MODX Evolution本体を最新版にアップデートする
※日本語版MODX Evolutionの場合はAjaxSearchが同梱されていないので、AjaxSearchも当トピックからダウンロードしてアップデートする必要があります。
添付ファイル
ajaxsearch.1.10.1J.zip
(300.77 KiB) ダウンロード数: 818 回
index-ajax.zip
(918 バイト) ダウンロード数: 835 回

“お知らせ” へ戻る